Read only file system on Android


I recently rooted my Droid X and everything seems to be working perfectly. I made some changes to build.prop and when I do adb push build.prop /system/ I get the following error: failed to copy 'c:\build.prop' to '/system//build.prop': Read-only file system.

How can I fix this?

All Answers
  • Translate

    Not all phones and versions of android have things mounted the same.
    Limiting options when remounting would be best.

    Simply remount as rw (Read/Write):

    # mount -o rw,remount /system

    Once you are done making changes, remount to ro (read-only):

    # mount -o ro,remount /system

  • Translate
    adb remount

    works for me and seems to be the simplest solution.

  • Translate

    Got this off an Android forum where I asked the same question. Hope this helps somebody else.

    On a terminal emulator on the phone:

    mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system

    Then on the cmd prompt, do the adb push

  • Translate

    While I know the question is about the real device, in case someone got here with a similar issue in the emulator, with whatever tools are the latest as of Feb, 2017, the emulator needs to be launched from the command line with:


    For anything to be writable to the /system. Without this flag no combination of remount or mount will allow one to write to /system.

    After the emulator is launched with that flag, a single adb remount after adb root is sufficient to get permissions to push to /system.

    Here's an example of the command line I use to run my emulator:

    ./emulator -writable-system -avd Nexus_5_API_25 -no-snapshot-load -qemu

    The value for the -avd flags comes from:

    ./emulator -list-avds

  • Translate

    I think the safest way is remounting the /system as read-write, using:

    mount -o remount,rw /system

    and when done, remount it as read-only:

    mount -o remount,ro /system

  • Translate

    On my Samsung galaxy mini S5570 (after got root on cellphone):

    Fist, as root, I ran:

    systemctl start adb

    as a normal user:

    adb shell 

    Grant root permissions on touch screen


    list all mount points that we have and we can see, in my case, that /dev/stl12 was mounted on /system as ro (ready only), so we just need do:

    mount -o rw,remount /dev/stl12 /system

  • Translate

    Try the following on the command prompt:

    >adb remount
    >adb push framework-res_old.apk /system/framework-res.apk

  • Translate
    adb disable-verity
    adb reboot
    adb root
    adb remount

    This works for me, and is the simplest solution.

  • Translate

    Here is what worked for me. I was running an emulated Android 7.1.1 (Nougat) device.

    On a terminal, I hit the following command. One thing to be noticed is the -writable-system flag

    ./emulator -writable-system -avd Nexus_6_API_25  -partition-size 280

    On another tab

    ./adb shell
    mount -o rw,remount -t ext4 /dev/block/vda /system

    All the changes that you do on the /system contents will survive a restart.

  • Translate

    Open terminal emulator on the phone: then

    adb shell

    after that daemon is started

    mount -o rw,remount /mnt/sdcard

    then the read only is converted into the read-Write.

  • Translate
    mount -o rw,remount /dev/stl12 /system

    works for me

  • Translate
    This worked for me
    #Mount as ReadOnly
    su -c "mount -o rw,remount /system"
    # Change Permission for file
    su -c "chmod 777 /system/build.prop" 
    #Edit the file to add the property
    su -c "busybox vi /system/build.prop"
    # Add now
    # Reset old permissions
    su -c "chmod 644 /system/build.prop"
    # Mount as readonly again once done
    su -c "mount -o ro,remount /system"

  • Translate

    I checked with emulator and following worked.

    1. adb reboot
    2. adb root && adb remount && adb push ~/Desktop/hosts /system/etc/hosts

    As mentioned above as well, execute second step in single shot.

  • Translate

    I found this article from google, and thought I'd add the steps necessary on a Sony Xperia Z (4.2.2).

    The Sony has a watchdog process which detects when you've changed ro to rw on / and /system (these are the only ones I was trying to modify) and possibly others.

    The following was what I ran to perform the changes I was trying to achieve. I pasted these into a window, because removing the execute bit from /sbin/ric needs to be done quickly in order to stop it restarting itself. (I tried stop ric; this doesn't work - although it worked on a previous version of android on the phone).

    pkill -9 ric; mount -o rw,remount -t rootfs /
    chmod 640 /sbin/ric
    mount -o rw,remount /system

    I modified the hosts file here, so this is the place you make the changes you need to the filesystem. To leave things the way we found them, do this:

    mount -o ro,remount /system
    chmod 750 /sbin/ric
    mount -o ro,remount -t rootfs /

    At which point ric should automatically restart. (It restarted for me automatically.)

  • Translate

    Adding a little bit more to Jan Bergström's answer: Because Android is a Linux based system, and the path in Linux contains forward slashes(../), while using push command, use "/" to define destination path in the Android device.

    For Example, the command goes: adb push C:\Users\admin\Desktop\1.JPG sdcard/pictures/

    Notice that here, back slashes are used to define source path of the file to be pushed from windows PC and forward slashes are used to define destination path because Android is a Linux based system. You don't have to act as a root to use this command and also, it works perfectly fine on production devices.

  • Translate

    Sometimes you get the error because the destination location in phone are not exist. For example, some android phone external storage location is /storage/emulated/legacy instead of /storage/emulated/0.

  • Translate

    Thanks, Sérgio, for "mount" command without parameters idea. I'd need to made adb push into /data/data/ for some test issue, and get "Read-only filesystem" message.

    ls command shows me:

    root@android:/ # ls -l /data/data/
    drwxrwx--x u0_a98 u0_a98 2016-05-06 09:16 cache drwxrwx--x u0_a98 u0_a98 2016-05-06 09:04 files lrwxrwxrwx system system 2016-05-06 11:43 lib -> /mnt/asec/

    So, it's understood, that "lib" directory is separated from other application directories.

    Command mount -o rw,remount /mnt/asec didn't resolve "r/o fs" issue, it wants device parameter before directory parameter.

    "df" command didn't help also, but shows that my /mnt/asec/ directory is at the separate mount point.

    Then I looks by mount and voila!

    root@android:/ # mount ......... /dev/block/dm-4 /mnt/asec/ ext4 ro,dirsync,relatime 0 0

    Next steps are already described upwards: remount to RW, push and remount back to RO.

  • Translate

    it sames that must extract and repack initrc.img and edit init file with the code of mount /system

  • Translate

    In my case I was using the command adb push ~/Desktop/file.txt ~/sdcard/

    I changed it to ~/Desktop/file.txt /sdcard/ and then it worked.

    Make sure to disconnect and reconnect the phone.

  • Translate

    If there's a failure in copying the read-only file you can try locating the original file in the root directory and modify it with a root text editor (preferably) RB text editor, it comes with ROM Toolbox app.

  • Translate

    Try this in a Terminal Emulator as root:

    restorecon -v -R /data/media

  • Translate

    Copy files to the SD-card?

    Well, I assume you like to copy data to the Sd-card from the developers computer? You might have rooted the devise and made the area you address available?) I had about the same problem to upload data files for my application(Android Studio 1.3.2 in Win7), but.

    • First the adb command-shell has to be found in th path: PATH=%PATH%;C:\Users\XXXXX\AppData\Local\Android\sdk\platform-tools (the folder AppData is hidden, so you have to set the folder setup not hiding concealed files and folder to find it, Path works regardless)
    • You have to spell the folder path right or you get a read-only error message, most likely it must start with /sdcard or it is read only area. As soon as I did no problem pushing the file to the emulator.

    So for instance the the adb command can look like this:

    adb push C:\testdata\t.txt /sdcard/download/t.txt