git - GitHub: Permission denied (publickey). fatal: The remote end hung up unexpectedly


Translate

I have followed these instructions below to upload a project.

Global setup:

 Download and install Git
  git config --global user.name "Your Name"
  git config --global user.email tirenga@gmail.com
  Add your public key


Next steps:

  mkdir tirengarfio
  cd tirengarfio
  git init
  touch README
  git add README
  git commit -m 'first commit'
  git remote add origin git@github.com:tirenga/tirenga.git
  git push origin master

But I get this error:

Permission denied (publickey). fatal: The remote end hung up unexpectedly


All Answers
  • Translate

    For me the problem was the execution of clone via sudo.

    If you clone to a directory where you have user permission ( /home/user/git) it will work fine.

    (Explanation: Running a command as superuser will not work with the same public key as running a command as user. Therefore Github refused the connection.)

    This solution requires a SSH key already to be set up: https://help.github.com/articles/generating-ssh-keys


  • Translate

    I had to add my public key to github. https://help.github.com/articles/generating-ssh-keys


  • Translate

    Yes, It's a public key Problem. I'm a windows user,and the page below help me resolve this problem.

    http://help.github.com/win-set-up-git/

    more precisely this link should be helpful

    https://help.github.com/articles/error-permission-denied-publickey


  • Translate

    after you created the RSA key pair, you must to add it to SSH using:

    ssh-add ~/.ssh/id_rsa
    

    or wherever you created your rsa key pair.


  • Translate

    Type the following command using your username and repository name:

    git clone https://github.com/{user name}/{repo name}
    

    in Ubuntu this works perfectly.


  • Translate

    I got a solution after a long time in tutorials.

    I followed the github tutorial on this link -> https://help.github.com/articles/error-permission-denied-publickey and I was able to connect in every step. But when I was trying to git push -u origin master I got this error:

    Permission denied (publickey). fatal: Could not read from remote repository.

    Please make sure you have the correct access rights

    Thats how I`ve fixed it!! Go to the project directory using the Terminal and check it out

    $git remote -v
    

    You will get something like this:

    origin  ssh://git@github.com/yourGithubUserName/yourRepo.git (fetch)
    origin  ssh://git@github.com/yourGithubUserName/yourRepo.git (push)
    

    If you are using anything different then git@github.com, open the config file on git directory by typing the command:

    vi .git/config
    

    And configure the line

    [remote "origin"]
    
    url = ssh://git@github.com/yourGithubUserName/yourRepo.git
    
    fetch = +refs/heads/*:refs/remotes/origin/
    

  • Translate

    In my case, I had to setup the public key for another user, as I already had one for my main user. once I switched users and performed the commands in the link above I was able to perform the setup for my test server without a problem.


  • Translate

    I had this problem, but none of the solutions above worked. I could clone and fetch but couldn't push. Eventually, I figured out the problem was in the url in my .git/config, it should be:

    git@github.com:<username>/<project>
    

    (not ssh://github.com/<username>/<project>.git or https://github.com/<username>/<project>.git).


  • Translate

    Given that none of the answers here worked for me, I finally tracked down my issue connecting to Bitbucket (or Github, doesn't matter in this case) with ssh -vT git@bitbucket.org.

    In my case, the failure was due to using a DSA key instead of RSA, and apparently my SSH client no longer allows that.

    debug1: Skipping ssh-dss key /c/Users/USER/.ssh/id_dsa for not in PubkeyAcceptedKeyTypes

    The solution was to add this to .ssh/config:

    Host *
        PubkeyAcceptedKeyTypes +ssh-dss
    

    This elegantly appends the ssh-dss key type to all existing accepted public key types and after this was done, git can now ssh into Bitbucket no problem.


  • Translate

    My issue was that I was trying to give my ssh key a SPECIFIC NAME every time I entered ssh-keygen on my mac terminal.

    I solved the issue by just leaving the name that "ssh-keygen" generates = id_rsa. You'll end up with 2 keys in your .ssh folder on a mac, id_rsa, which is your private key, and the id_rsa.pub, which is your public key. Then I copied and saved the code from id_rsa.pub into my GitHub account settings, and that was it. Problem solved.


  • Translate

    A good one if you have installed git on your computer:

    http://help.github.com/mac-set-up-git/


  • Translate

    Adding public key is the solution.For generating ssh keys: https://help.github.com/articles/generating-ssh-keys has step by step instructions.

    However, the problem can persist if key is not generated in the correct way. I found this to be a useful link too: https://help.github.com/articles/error-permission-denied-publickey

    In my case the problem was that I was generating the ssh-key without using sudo but when using git commands I needed to use sudo. This comment in the above link "If you generate SSH keys without sudo, then when you try to use a command like sudo git push, you won't be using the SSH key you generated." helped me.

    So, the solution was that I had to use sudo with both key generating commands and git commands. Or for others, when they don't need sudo anywhere, do not use it in any of the two steps. (key generating and git commands).


  • Translate

    I faced a similar issue when running SSH or Git Clone in Windows. Following findings helps to solve my problem:

    • When you run “rhc setup” or other ssh methods to generate ssh key, it will create the private key file id_rsa in .ssh folder in your home folder, default is C:\User\UserID
    • Git for windows has its own .ssh folder in its installation directory. When you run git/ssh, it will look for private key file id_rsa in this folder
    • Solved the problem by copying id_rsa from the home folder .ssh folder to the .ssh folder in the git installation directory

    Also, I think there a way to “tell” git to use the default .ssh folder in home folder but still need to figure out how.


  • Translate

    For me, it worked like this:

    In GitHub I changed the ssh link to https, and then gave the following commands:

    $ git init
    $ git remote add origin https:...
    $ git add .
    $ git commit -m "first commit"
    $ git push origin master
    

  • Translate

    Use ubuntu on windows store

    windows subsystem for linux

    , your git push will work across different accounts.


  • Translate

    If you are using a linux machine then check,

    • do you have Openssh installed
    • if you do, then do you have an existing public key otherwise you'll have to generate one.
    • is your public key added to your github account.

    Generating new SSH keys and adding them to my Github account solved my problem. You can look into this page for more details. GitHelp.


  • Translate

    You can try change your type connection to branch from ssh to https.

    1. nano project_path/.git/config
    2. Replace git@github.com:username/repository.git to https://username@github.com/username/repository_name.git
    3. Save file ctrl + o

    After that you can try git pull without publickey


  • Translate

    You need to set up SSH keys.

    This GitHub page explains how to generate keys.

    If you have an existing key, you copy $HOME/.ssh/id_rsa.pub and paste it into the GitHub SSH settings page.


  • Translate

    A quick way to fix this if you're using a Mac is to sign out of the OSX app and log back in.


  • Translate

    My problem was that it didn't work with a passphrase on my private key.

    Hope that helps someone.


  • Translate

    I also have this problem today. The solution is setting your "ssh key". Click the url below, follow the steps, then you will sovle it.

    http://github.com/guides/providing-your-ssh-key


  • Translate

    I tried the solutions mentioned but still failed. I found the solution that finally worked for me here - removing then re-adding the remote link


  • Translate

    I had the same issue on windows. I switched from SSH to HTTPS and ran a Git PUSH.

    git push -u origin master
    Username for 'https://github.com': <Github login email>
    Password for <Github login>: xxx
    

    Successful! hope this helps.