.net - TestDriven.NET non esegue i miei metodi SetUp per MbUnit

original title: ".net - TestDriven.NET is not running my SetUp methods for MbUnit"


I've created some MbUnit Test Fixtures that have SetUp methods marked with the SetUp attribute. These methods run before the tests just fine using the MbUnit GUI, the console runner, and the ReSharper MbUnit plugin. However, when I run the tests with TestDriven.NET it does not run the SetUp methods at all.

Does anyone know if this is a bug with TestDriven.NET or if I have something setup wrong?

Ho creato alcuni dispositivi di prova MbUnit con metodi SetUp contrassegnati con l'attributo SetUp. Questi metodi vengono eseguiti correttamente prima dei test utilizzando la GUI MbUnit, il runner della console e ReSh ...

Questo è il riepilogo dopo la traduzione, se è necessario visualizzare la traduzione completa, fare clic sull'icona "traduci"

Tutte le risposte
  • Translate

    No longer an issue with recent versions of Gallio since v3.0.4. Just make sure to use the 64-bit installer.

  • Translate

    After having this problem for weeks on Vista 64, I found a post by Dave Bouwman just today, and it fixed this problem.

  • Translate

    I had this exact same issue after installing NUnit using nuget ... previously I had been using an older version of NUnit and everything had worked fine.

    I think TestDriven is not compatible with the latest version of NUnit.

    I've switched to using NCrunch, which is free, and compiles/runs tests in the backgound as you are coding, amongst other things. Highly recommended.