html - How do you disable browser Autocomplete on web form field / input tag?


Translate

How do you disable autocomplete in the major browsers for a specific input (or form field)?


Alle Antworten
  • Translate

    Firefox 30 ignores autocomplete="off" for passwords, opting to prompt the user instead whether the password should be stored on the client. Note the following commentary from May 5, 2014:

    • The password manager always prompts if it wants to save a password. Passwords are not saved without permission from the user.
    • We are the third browser to implement this change, after IE and Chrome.

    According to the Mozilla Developer Network documentation, the Boolean form element attribute autocomplete prevents form data from being cached in older browsers.

    <input type="text" name="foo" autocomplete="off" />
    

  • Translate

    In addition to autocomplete=off, you could also have your form fields names be randomized by the code that generates the page, perhaps by adding some session-specific string to the end of the names.

    When the form is submitted, you can strip that part off before processing them on the server side. This would prevent the web browser from finding context for your field and also might help prevent XSRF attacks because an attacker wouldn't be able to guess the field names for a form submission.


  • Translate

    Most of the major browsers and password managers (correctly, IMHO) now ignore autocomplete=off.

    Why? Many banks and other "high security" websites added autocomplete=off to their login pages "for security purposes" but this actually decreases security since it causes people to change the passwords on these high-security sites to be easy to remember (and thus crack) since autocomplete was broken.

    Long ago most password managers started ignoring autocomplete=off, and now the browsers are starting to do the same for username/password inputs only.

    Unfortunately, bugs in the autocomplete implementations insert username and/or password info into inappropriate form fields, causing form validation errors, or worse yet, accidentally inserting usernames into fields that were intentionally left blank by the user.

    What's a web developer to do?

    • If you can keep all password fields on a page by themselves, that's a great start as it seems that the presence of a password field is the main trigger for user/pass autocomplete to kick in. Otherwise, read the tips below.
    • Safari notices that there are 2 password fields and disables autocomplete in this case, assuming it must be a change password form, not a login form. So just be sure to use 2 password fields (new and confirm new) for any forms where you allow
    • Chrome 34, unfortunately, will try to autofill fields with user/pass whenever it sees a password field. This is quite a bad bug that hopefully, they will change the Safari behavior. However, adding this to the top of your form seems to disable the password autofill:

      <input type="text" style="display:none">
      <input type="password" style="display:none">
      

    I haven't yet investigated IE or Firefox thoroughly but will be happy to update the answer if others have info in the comments.


  • Translate

    Sometimes even autocomplete=off would not prevent to fill in credentials into wrong fields, but not user or nickname field.

    This workaround is in addition to apinstein's post about browser behavior.

    fix browser autofill in read-only and set writable on focus (click and tab)

     <input type="password" readonly  
         onfocus="this.removeAttribute('readonly');"/>
    

    Update: Mobile Safari sets cursor in the field, but does not show virtual keyboard. New Fix works like before but handles virtual keyboard:

    <input id="email" readonly type="email" onfocus="if (this.hasAttribute('readonly')) {
        this.removeAttribute('readonly');
        // fix for mobile safari to show virtual keyboard
        this.blur();    this.focus();  }" />
    

    Live Demo https://jsfiddle.net/danielsuess/n0scguv6/

    // UpdateEnd

    Because Browser auto fills credentials to wrong text field!?

    I notice this strange behavior on Chrome and Safari, when there are password fields in the same form. I guess, the browser looks for a password field to insert your saved credentials. Then it auto fills (just guessing due to observation) the nearest textlike-input field, that appears prior the password field in DOM. As the browser is the last instance and you can not control it,

    This readonly-fix above worked for me.


  • Translate
    <form name="form1" id="form1" method="post" 
          autocomplete="off" action="http://www.example.com/form.cgi">
    

    This will work in Internet Explorer and Mozilla FireFox, the downside is that it is not XHTML standard.


  • Translate

    The solution for Chrome is to add autocomplete="new-password" to the input type password.

    Example:

    <form name="myForm"" method="post">
    <input name="user" type="text" />
    <input name="pass" type="password" autocomplete="new-password" />
    <input type="submit">
    </form>
    

    Chrome always autocomplete the data if it finds a box of type password, just enough to indicate for that box autocomplete = "new-password".

    This works well for me.

    Note: make sure with F12 that your changes take effect, many times browsers save the page in cache, this gave me a bad impression that it did not work, but the browser did not actually bring the changes.


  • Translate

    As others have said, the answer is autocomplete="off"

    However, I think it's worth stating why it's a good idea to use this in certain cases as some answers to this and duplicate questions have suggested it's better not to turn it off.

    Stopping browsers storing credit card numbers shouldn't be left to users. Too many users won't even realize it's a problem.

    It's particularly important to turn it off on fields for credit card security codes. As this page states:

    "Never store the security code ... its value depends on the presumption that the only way to supply it is to read it from the physical credit card, proving that the person supplying it actually holds the card."

    The problem is, if it's a public computer (cyber cafe, library etc) it's then easy for other users to steal your card details, and even on your own machine a malicious website could steal autocomplete data.


  • Translate

    I'd have to beg to differ with those answers that say to avoid disabling auto-complete.

    The first thing to bring up is that auto-complete not being explicitly disabled on login form fields is a PCI-DSS fail. In addition, if a users' local machine is compromised then any autocomplete data can be trivially obtained by an attacker due to it being stored in the clear.

    There is certainly an argument for usability, however there's a very fine balance when it comes to which form fields should have autocomplete disabled and which should not.


  • Translate

    Three options: First:

    <input type='text' autocomplete='off' />
    

    Second:

    <form action='' autocomplete='off'>
    

    Third (javascript code):

    $('input').attr('autocomplete', 'off');
    

  • Translate

    I've solved the endless fight with Google Chrome with the use of random characters. When you always render autocomplete with random string, it will never remember anything.

    <input name="name" type="text" autocomplete="rutjfkde">
    

    Hope that it will help to other people.


  • Translate

    On a related or actually, on the completely opposite note -

    "If you're the user of the aforementioned form and want to re-enable the autocomplete functionality, use the 'remember password' bookmarklet from this bookmarklets page. It removes all autocomplete="off" attributes from all forms on the page. Keep fighting the good fight!"


  • Translate

    We did actually use sasb's idea for one site. It was a medical software web app to run a doctor's office. However, many of our clients were surgeons who used lots of different workstations, including semi-public terminals. So, they wanted to make sure that a doctor who doesn't understand the implication of auto-saved passwords or isn't paying attention can't accidentally leave their login info easily accessible. Of course, this was before the idea of private browsing that is starting to be featured in IE8, FF3.1, etc. Even so, many physicians are forced to use old school browsers in hospitals with IT that won't change.

    So, we had the login page generate random field names that would only work for that post. Yes, it's less convenient, but it's just hitting the user over the head about not storing login information on public terminals.


  • Translate

    Just set autocomplete="off". There is a very good reason for doing this: You want to provide your own autocomplete functionality!


  • Translate

    I've been trying endless solutions, and then I found this:

    Instead of autocomplete="off" just simply use autocomplete="false"

    As simple as that, and it works like a charm in Google Chrome as well!


  • Translate

    I think autocomplete=off is supported in HTML 5.

    Ask yourself why you want to do this though - it may make sense in some situations but don't do it just for the sake of doing it.

    It's less convenient for users and not even a security issue in OS X (mentioned by Soren below). If you're worried about people having their passwords stolen remotely - a keystroke logger could still do it even though your app uses autcomplete=off.

    As a user who chooses to have a browser remember (most of) my information, I'd find it annoying if your site didn't remember mine.


  • Translate

    None of the solutions worked for me in this conversation.

    I finally figured out a pure HTML solution that requires no Javascript, works in modern browsers (except IE; there had to at least 1 catch, right?), and does not require you to disable autocomplete for the entire form.

    Simply turn off autocomplete on the form and then turn it ON for any input you wish it to work within the form. For example:

    <form autocomplete="off">
        <!-- these inputs will not allow autocomplete and chrome 
             won't highlight them yellow! -->
        <input name="username"  />
        <input name="password" type="password" />
        <!-- this field will allow autocomplete to work even 
             though we've disabled it on the form -->
        <input name="another_field" autocomplete="on" />
    </form>
    

  • Translate

    This works for me.

    <input name="pass" type="password" autocomplete="new-password" />
    

    We can also use this strategy in other controls like text, select etc


  • Translate

    A little late to the game...but I just ran into this problem and tried several failures, but this one works for me found on MDN

    In some case, the browser will keep suggesting autocompletion values even if the autocomplete attribute is set to off. This unexpected behavior can be quite puzzling for developers. The trick to really force the no-completion is to assign a random string to the attribute like so :

    autocomplete="nope"
    

  • Translate

    The best solution:

    Prevent autocomplete username (or email) and password:

    <input type="email" name="email"><!-- Can be type="text" -->
    <input type="password" name="password" autocomplete="new-password">
    

    Prevent autocomplete a field:

    <input type="text" name="field" autocomplete="nope">
    

    Explanation: autocomplete continues work in <input>, autocomplete="off" does not work, but you can change off to a random string, like nope.

    Works in:

    • Chrome: 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63 and 64

    • Firefox: 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57 and 58


  • Translate

    Try to add

    readonly onfocus="this.removeAttribute('readonly');"

    in addition to

    autocomplete="off"

    to the input(s) that you do not want to remember form data (username, password, etc.) as shown below:

    <input type="text" name="UserName" autocomplete="off" readonly 
        onfocus="this.removeAttribute('readonly');" >
    
    <input type="password" name="Password" autocomplete="off" readonly 
        onfocus="this.removeAttribute('readonly');" >
    


    Update: Here is full example below based on this approach that prevents from drag & drop, copy, paste, etc.

    <input type="text" name="UserName" style="text-transform:lowercase;" placeholder="Username" 
        autocomplete="off" readonly onfocus="this.removeAttribute('readonly');" 
        oncopy="return false" ondrag="return false" ondrop="return false" 
        onpaste="return false" oncontextmenu="return false" > 
    
    <input type="password" name="Password" placeholder="Password" autocomplete="off" readonly 
        onfocus="this.removeAttribute('readonly');" oncopy="return false" ondrag="return false" 
        ondrop="return false" onpaste="return false" oncontextmenu="return false" >
    

    Tested on the latest versions of the major browsers i.e. Google Chrome, Mozilla Firefox, Microsoft Edge, etc. and working without any problem. Hope this helps...


  • Translate

    Adding the

    autocomplete="off"

    to the form tag will disable the browser autocomplete (what was previously typed into that field) from all input fields within that particular form.

    Tested on:

    • Firefox 3.5, 4 BETA
    • Internet Explorer 8
    • Chrome

  • Translate

    Use a non-standard name and id for the fields, so rather than "name" have "name_". Browsers will then not see it as being the name field. The best part about it is that you can do this to some but not all fields and it will autocomplete some but not all fields.


  • Translate

    In order to avoid the invalid XHTML you can set this attribute using javascript. Example using jQuery:

    <input type="text" class="noAutoComplete" ... />
    
    $(function() {
        $('.noAutoComplete').attr('autocomplete', 'off');
    });
    

    The problem is that users without javascript will do get the autocomplete functionality.


  • Translate

    Adding autocomplete="off" is not gonna cut it.

    Change input type attribute to type="search".
    Google doesn't apply auto-fill to inputs with a type of search.


  • Translate

    try these too if just autocomplete="off" doesn't work:

    autocorrect="off" autocapitalize="off" autocomplete="off"
    

  • Translate

    I can't believe this is still an issue so long after it's been reported. The above solutions didn't work for me, as safari seemed to know when the element was not displayed or off-screen, however the following did work for me:

    <div style="height:0px; overflow:hidden; ">
      Username <input type="text" name="fake_safari_username" >
      Password <input type="password" name="fake_safari_password">
    </div>
    

    Hope that's useful for somebody!


  • Translate

    This is a security issue that browsers ignore now. Browsers identify and stores content using input names, even if developers consider the information is sensitive and should not be stored. Making an input name different between 2 requests will solve the problem (but will still be saved in browser's cache and will also increase browser's cache). Ask the user to activate or deactivate options in its browser's settings is not a good solution. The issue can be fixed in the backend.

    Here's my fix. An approach that I have implemented in my framework. All autocomplete elements are generated with an hidden input like this :

    <? $r = rmd5(rand().mocrotime(TRUE)); ?>
    <form method="POST" action="./">
        <input type="text" name="<? echo $r; ?>" />
        <input type="hidden" name="__autocomplete_fix_<? echo $r; ?>" value="username" />
        <input type="submit" name="submit" value="submit" />
    </form>
    

    Server then process post variables like this :

    foreach ($_POST as $key => $val)
    {
        if(preg_match('#^__autocomplete_fix_#', $key) === 1){
            $n = substr($key, 19);
            if(isset($_POST[$n]))$_POST[$val] = $_POST[$n];
        }
    }
    

    The value can be accessed as usual

    var_dump($_POST['username']);
    

    And the browser won't be able to suggest information from the previous request or from previous users.

    All works like a charm, even if browsers updates, want to ignore autocomplete or not. That has been the best way to fix the issue for me.


  • Translate

    None of the hacks mentioned here worked for me in Chrome. There's a discussion of the issue here: https://code.google.com/p/chromium/issues/detail?id=468153#c41

    Adding this inside a <form> works (at least for now):

    <div style="display: none;">
        <input type="text" id="PreventChromeAutocomplete" name="PreventChromeAutocomplete" autocomplete="address-level4" />
    </div>
    

  • Translate

    So here is it:

    function turnOnPasswordStyle() {
      $('#inputpassword').attr('type', "password");
    }
    <input oninput="turnOnPasswordStyle()" id="inputpassword" type="text">

  • Translate

    You may use in input.

    For example;

    <input type=text name="test" autocomplete="off" />