asp.net - Visual Studio "Unable to start debugging on the web server. The web server did not respond in a timely manner."


Translate

I get the following error pretty regularly when compiling in Visual Studio and running my web application:

"Unable to start debugging on the web server. The web server did not respond in a timely manner. This may be because another debugger is already attached to the web server."

Normally this is after having debug the application once already. From the command line I run "iisreset /restart" and it fixes the problem.

How do I prevent this from happening in the first place?


所有的回答
  • Translate

    I find that this happens if I'm debugging with Firefox as my browser. When I exit Firefox the VS2005/8 debug session doesn't terminate. I have not found a solution for this (yet).

    If this is what's happening with you then a quicker solution than running iisreset is to hit Shift-F5 when in Visual Studio and this will terminate the current debug session. You can then hit F5 and this will start a new debug session.


  • Translate

    The solution that worked for me:

    1. Open Command Prompt (Run as Administrator)

    2. Write iisreset /restart

    3. Now, go back to your VS and debug. It will debug your solution.

    It worked for Visual Studio 2013 and 2015 too in my case.


  • Translate

    After trying all of the proposed solutions here and in other places (at least 10 different approaches), the only option that worked for me was:

    • delete website and application pool on IIS
    • re-create website and application pool on IIS (in my case, everything exactly the same config as before)

    PS: I am using VS 2013 and IIS 7.5 (Win7).

    I hope this saves someone else a few hours.


  • Translate

    We use another way of debugging, we never use F5 anymore.

    We use a macro kind of like: http://blogs.conchango.com/howardvanrooijen/archive/2007/06/24/Attach-to-Web-Server-Macro-for-Visual-Studio.aspx (Which we bound to F6).

    This way you simply attach the debugger to IIS. It's (depending on project size) much quicker to make you changes, compile a single project that you changed and attach the debugger again.


  • Translate

    solution:go to task manager and end process aspnet_wp.exe before running application


  • Translate

    I have had this problem a couple times. One time it was resolved by taking Guy's advice:

    If this is what's happening with you then a quicker solution than running iisreset is to hit Shift-F5 when in Visual Studio and this will terminate the current debug session. You can then hit F5 and this will start a new debug session.

    On a separate occasion I had to: terminate all my iis worker processes in the windows task manager (w3wp.exe*). You should be able to hit f5 in visual studio to debug.


  • Translate

    It sounds like you are probably hitting F5 in Visual Studio when you receive this error?

    There are a few things you can try. The easiest is to hit the Stop button before hitting F5. Optionally, when you are finished debugging and starting to make changes you can go to the Debug menu and choose either Stop Debugging or Terminate All.


  • Translate

    For me I had two visual studio open. The debugger already was attached to another visual studio :). I stopped it on the first one and was able to attach on the second visual studio.


  • Translate

    When debugging 2 web application (1 MVC and 2 is MVC WebAPI) that are both hosted in the local IIS. Make sure that each application is using a different application pool. I encountered the same issue and as soon as I change the app pool of the other one, it worked!


  • Translate

    If you have a lot of break points this will slow the debugging process down, so remove unneeded break points and close the Autos window this will solve your problem


  • Translate

    I saw this message first time in my life and I was very confused about what is going on as it is not pretty obvious what to do.

    I ran iisreset and it took just 1 sec to finish the execution, and boom, I was back into the game.

    P.S. I am using chrome


  • Translate

    Hit Shift+F5 when in Visual Studio and this will terminate the current debug session. You can then hit F5 and this will start a new debug session.

    or

    close your application, reset iis then open your application and run it


  • Translate

    Very basic - but check that if you try to run the web site from IIS by clicking on "Browse", the site actually runs.


  • Audrey Lee
    Translate

    It sounds like something is eating up your web server's resources. Perhaps you have some resources (file handlers, wcf proxies) that are being opened and not closed? I've had this happen to me specifically when I was not closing WCF client proxy connections.

    The problem is not necessarily that you have a debugger attached, but only that the web server is not responding in a timely manner. Note that the message says "This may be because another debugger is attached".


  • Ida Lee
    Translate

    The issue is normally there when an another instance of iexplore is still running. I used to have the issue when my IE crashes but I can still see it in the Task Manager. Once you "End Process" everything is back to normal :)


  • Translate

    This answer will only apply if you are running your solution through IIS. You will know if this applies to you IF you open up your website/project by doing the following: From within visual studio-->Open Website--> Local IIS -->Select your project

    This error Kicked my butt for 4 hours but finally i found an answer. I first attempted the iisreset /restart. This seemed to slightly help but still received the same error.

    What worked for me was going (xp machine) to add/remove programs --> Add/Remove Windows Components--> Click on IIS--> Click on "Details". Be sure to have Front Page Extensions installed if you are debugging through IIS.


  • Translate

    If all the answers does not work for you, just end process all iis related components in task manager. This is what worked for me.


  • Translate

    I ran into this issue when trying to debug (2) separate solutions in VS.NET and both were using the IIS Web Server to launch the app. The 1st application will start, but any subsequent applications started that also run via IIS will then display that error. It seems that it can only debug a single application via VS.NET hosted in IIS at a time.

    The solution: run project 1 from VS.NET (place any needed breakpoints) and start the second application directly from IIS (not VS.NET). Your breakpoints in App 1 (running in VS.NET) will be hit when accessing App 2 (ran from IIS directly).


  • Translate

    This happens to me quite a bit in VS 2010 express - Usually because the debugger stopped responding. Right click windows taskbar, select 'Start Task Manager'. More than likely the ASP.NET debugger will be showing a 'not responding' status. Select it and simply terminate the process.

    Done!


  • Translate

    With me it happened when IE was upgraded to newer version, went to Installed Updates, removed new version of IE, after computer restarted it went back to old version and problem with debugging was solved


  • Translate

    Had the same problem, even after a reboot. Basically did this:

    1. Restart IIS
    2. Clean Solution
    3. Rebuild Solution

    Then it started working again.


  • Translate

    This can also be caused if your website uses a database connection but the database server is unavailable.

    I spent some time trying to resolve this issue in the usual ways, but even after restarting my workstation, the issue remained. Eventually I found that the SQL Server (MSSQLSERVER) service was not running.

    It should have been running, as it's set to Automatic, but it was stopped, even after the reboot. All the MSSQLSERVER events in the event log appeared normal, so it remains unknown why it wasn't running, but I have now set it to Automatic (delayed start) in the hope that this will reduce resource contention during startup.

    Once I started MSSQLSERVER , the message "Unable to start debugging on the web server. The web server did not respond in a timely manner" no longer appeared and normal service was resumed.


  • Translate

    I had to recreate the site/application/virtual directory to make it work after I installed vs2015 update3. Hope this helps someone. ;)


  • Translate

    I know this is an old question, but I met the same situation recently and try every solution in this post, and no luck. Finally, I found the solution that works for me:

    1. Close Visual Studio
    2. Find Turn Windows features on or off in Control Panel
    3. Uncheck Internet Information Services in the popup dialog
    4. Restart your computer
    5. Check Internet Information Services in the same dialog, and make sure Internet Information Service -> World Wide Web Services -> Application Development Features -> ASP.NET also been checked
    6. Open Visual Studio, and now your application should be able to run in debug mode

  • Verna Lee
    Translate

    Open

    • Options and Settings Under the debug
    • Symbols and unchecked Microsoft Symbol Servers
    • build solution
    • iisreset
    • F5 solution (Be sure Microsoft Symbol Servers unchecked again)

  • Translate

    This worked for me by @mtkachenko Visual Studio 2012: Unable to attach the process. A debugger is already attached "I have installed Debug Diagnostic Tool v2.0 and as a result I have Debug Diagnostic Service which is started automatically and attached to one of w3wp processes. After turning off and disabling this service all works fine. So if you get such error check processes in task manager which can capture your w3wp process"


  • Translate

    I just solved this problem on my machine. My problem is that I upgraded IE 9 To IE 10 and I got this error. Solution : Remove IE 10 and downgrade to IE 9. Go to "Programs and Features" --> "View recent updates" --> find IE 10---> Uninstall it-->reboot--->ie 9 is back--->debug--->works OK.


  • Translate

    Try performing either of the following steps to resolve your issue:

    • Restart your IIS Server
    • Clean the Solution of your project then build again

    If above steps do not help, you can finally try restarting your machine


  • Translate

    in your cmd type iisreset and press enter after that your iis is reset and your application is working perfectly


  • Translate

    In my case it gets solve deleting all breakpoints. Looks like i had a lot of breakpoints(conditional and not conditional) and it was causing lack of resources .